Nordic Softdevice BLE

Provides a RIOT adaption for Nordic Softdevice BLE library. More...

Detailed Description

Provides a RIOT adaption for Nordic Softdevice BLE library.

Deprecated:
Will be removed after the 2020.10 release.

Use nimble for BLE support instead.

Overview

This package provides necessary Makefiles and glue code to use the Nordic S132 SoftDevice as Bluetooth BLE transport for RIOT's 6lowpan stack.

Usage

"gnrc_netdev_default" has a dependency to "nordic_softdevice_ble", so all examples automatically download the SDK and compile / link / flash all needed code.

If you want to manually set up included modules, add "USEPKG += nordic_softdevice_ble" to your application's Makefile.

See README-BLE-6LoWPAN.md for instructions on how to set up 6lowpan over BLE on Linux.

Known issues

Files

file  ble-mac.h
 Public API and definitions of Nordic Softdevice BLE.